?

Log in

No account? Create an account
entries friends calendar profile my webpage Previous Previous Next Next
Any RH people out there? - Tina Marie's Ramblings
Red hair and black leather, my favorite colour scheme...
skywhisperer
skywhisperer
Any RH people out there?
I'm trying to run up2date. I've got about 50 packages that need updated, but it won't update any of them because:
package spamassassin-3.1.0-1 (which is newer than spamassassin-3.0.5-3.el4) is already installed
I know that. I want it to ignore that package. I have:
6. fileSkipList ['spamassassin*']
20. pkgSkipList ['no.kernel*', ' spamassassin*']
But I keep getting that same error. I won't rollback spamassassin to the version on the RH site because the new one is light-years better. And I could update each package individually, but darn it, this is why I wanted to use up2date to begin with!

Virtual chocolate to someone who can figure out what I'm doing wrong. :)

Edit: And I'm buying myself chocolate. See the space before spamassassin on the skip list entry? Yep, that was the problem. I am an idiot.

Tags:
Current Mood: annoyed annoyed

3 comments or Leave a comment
Comments
ptomblin_lj From: ptomblin_lj Date: March 18th, 2006 02:37 am (UTC) (Link)
Do an "rpm -q --whatrequires spamassassin" to see if anything depends on it. On my system, evolution requires it. Maybe you should remove those things, allow up2date to run, and then re-install them.
aladdin_sane From: aladdin_sane Date: March 18th, 2006 10:31 am (UTC) (Link)

Any RH people out there?

yes, I am right handed. :) Enjoy the chocolate. :)
alioth1 From: alioth1 Date: March 18th, 2006 11:21 am (UTC) (Link)
On a related note, if you have any spare hardware at home, you can make yourself a test box using CentOS 4. CentOS shadows Red Hat Enterprise Linux, so it'll give you a good idea of what's going to happen and you can configure it in the same way.
3 comments or Leave a comment